Commit 0938a372 authored by Moul's avatar Moul

[mod] #1358: Remove Loki dependencies and import

parent 0602cd20
......@@ -27,7 +27,6 @@ import {DataErrors} from "../../../../../lib/common-libs/errors"
import {ProtocolIndexesStream} from "./ProtocolIndexesStream"
const constants = require('../../constants')
const loki = require('lokijs')
let sync_expires: number[] = []
let sync_bindex: any [] = []
......
......@@ -84,7 +84,6 @@
"js-yaml": "3.8.2",
"leveldown": "^4.0.1",
"levelup": "^4.0.0",
"lokijs": "^1.5.3",
"memdown": "^3.0.0",
"merkle": "0.5.1",
"moment": "2.19.3",
......@@ -115,7 +114,6 @@
"ws": "1.1.5"
},
"devDependencies": {
"@types/lokijs": "^1.5.2",
"@types/mocha": "^2.2.41",
"@types/node": "^8.0.9",
"@types/should": "^8.3.0",
......
......@@ -51,10 +51,6 @@
version "4.14.104"
resolved "https://registry.yarnpkg.com/@types/lodash/-/lodash-4.14.104.tgz#53ee2357fa2e6e68379341d92eb2ecea4b11bb80"
"@types/lokijs@^1.5.2":
version "1.5.2"
resolved "https://registry.yarnpkg.com/@types/lokijs/-/lokijs-1.5.2.tgz#ed228f080033ce1fb16eff4acde65cb9ae0f1bf2"
"@types/marked@0.3.0":
version "0.3.0"
resolved "https://registry.yarnpkg.com/@types/marked/-/marked-0.3.0.tgz#583c223dd33385a1dda01aaf77b0cd0411c4b524"
......@@ -2620,10 +2616,6 @@ log-driver@1.2.4:
version "1.2.4"
resolved "https://registry.yarnpkg.com/log-driver/-/log-driver-1.2.4.tgz#2d62d7faef45d8a71341961a04b0761eca99cfa3"
lokijs@^1.5.3:
version "1.5.3"
resolved "https://registry.yarnpkg.com/lokijs/-/lokijs-1.5.3.tgz#6952722ffa3049a55a5e1c10ee4a0947a3e5e19b"
longest@^1.0.1:
version "1.0.1"
resolved "https://registry.yarnpkg.com/longest/-/longest-1.0.1.tgz#30a0b2da38f73770e8294a0d22e6625ed77d0097"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment