Skip to content
  • Florian Thöni's avatar
    OSx bundle opening in GUI resolution · 7ecbc257
    Florian Thöni authored
    We need to enforce locale environment variable for encoding to be
    able to read files.
    
    But this can not be created directly by the spec file, then we need
    to enforce the Info.plist file
    
    Here is why (extract from https://pythonhosted.org/PyInstaller/spec-files.html#spec-file-options-for-a-mac-os-x-bundle):
    The info_plist= parameter only handles simple key:value pairs. It cannot handle nested XML arrays. For example, if you want to modify Info.plist to tell Mac OS X what filetypes your app supports, you must add a CFBundleDocumentTypes entry to Info.plist (see Apple document types). The value of that keyword is a list of dicts, each containing up to five key:value pairs.
    
    To add such a value to your app’s Info.plist you must edit the plist file separately after PyInstaller has created the app. However, when you re-run PyInstaller, your changes will be wiped out. One solution is to prepare a complete Info.plist file and copy it into the app after creating it.
    7ecbc257