Commit 4f772671 authored by Moul's avatar Moul

[fix] 'poetry run' cli parsing changed in 1.0.0b3:

- '--' is necessary to pass options
- Update documentation and CI
- See https://github.com/sdispater/poetry/issues/1500
parent e135fa15
...@@ -63,8 +63,8 @@ tests-3.7-coverage: ...@@ -63,8 +63,8 @@ tests-3.7-coverage:
tags: [poetry-78] tags: [poetry-78]
script: script:
- poetry install - poetry install
- poetry run pytest --cov silkaj --cov-report html:cov_html - poetry run -- pytest --cov silkaj --cov-report html:cov_html
- poetry run coverage-badge -o cov_html/coverage.svg - poetry run -- coverage-badge -o cov_html/coverage.svg
artifacts: artifacts:
paths: paths:
- cov_html - cov_html
......
...@@ -37,5 +37,5 @@ You might need to enter Poetry shell to access development tools such as `pytest ...@@ -37,5 +37,5 @@ You might need to enter Poetry shell to access development tools such as `pytest
Add following alias to your shell configuration: Add following alias to your shell configuration:
```bash ```bash
alias silkaj="cd /path/to/silkaj/silkaj && poetry run silkaj" alias silkaj="cd /path/to/silkaj/silkaj && poetry run -- silkaj"
``` ```
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment