Commit ceb84095 authored by Moul's avatar Moul
Browse files

[enh] 3.8: Install git, pre-commit, isort, and pyupgrade

pre-commit is not available in Buster, will be in Bullseye
parent 72dd5b61
Pipeline #12994 passed with stage
in 4 minutes and 20 seconds
......@@ -2,8 +2,8 @@ FROM python:3.8-slim-buster
# Install libsodium
RUN apt update && \
apt install --yes libsodium23 make && \
apt install --yes libsodium23 make git && \
rm -rf /var/lib/apt/lists
# Install Poetry
RUN pip install poetry black mypy pylint sphinx_rtd_theme
RUN pip install poetry pre-commit black isort mypy pylint pyupgrade sphinx_rtd_theme
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment