Commit 32236bb3 authored by Éloïs's avatar Éloïs

Change project architecture (no code change)

parent f016ab94
......@@ -396,7 +396,7 @@ dependencies = [
[[package]]
name = "durs"
version = "0.1.0-a0.1"
version = "0.1.0-a1"
dependencies = [
"duniter-core 0.1.0-a0.1",
"duniter-tui 0.1.0-a0.1",
......
[package]
name = "durs"
version = "0.1.0-a0.1"
authors = ["librelois <elois@duniter.org>","nanocryk <nanocryk@duniter.org>"]
description = "DUniter-RS (durs) is a new implementation of Duniter protocol and software in Rust, a safe, concurrent, practical language"
license = "AGPL-3.0"
[dependencies]
duniter-core = { path = "./core" }
# durs-skeleton-module = { path = "./skeleton-module" }
durs-ws2p = { path = "./ws2p" }
durs-ws2p-v1-legacy = { path = "./ws2p-v1-legacy" }
structopt= "0.2.*"
[target.'cfg(unix)'.dependencies]
duniter-tui = { path = "./tui" }
[features]
default = ["ssl"]
ssl = ["durs-ws2p-v1-legacy/ssl"]
# Treat warnings as a build error.
strict = []
[workspace]
members = [
"blockchain",
"conf",
"core",
"crypto",
"dal",
"documents",
"message",
"module",
"network",
"network-documents",
# "skeleton-module",
"tui",
"wot",
"ws2p",
"ws2p-messages",
"ws2p-v1-legacy"
"bin/durs-server",
"lib/blockchain",
"lib/conf",
"lib/core",
"lib/crypto",
"lib/dal",
"lib/documents",
"lib/message",
"lib/module",
"lib/network",
"lib/network-documents",
# "lib/skeleton-module",
"lib/tui",
"lib/wot",
"lib/ws2p",
"lib/ws2p-messages",
"lib/ws2p-v1-legacy"
]
[package]
name = "durs"
version = "0.1.0-a1"
authors = ["librelois <elois@duniter.org>","nanocryk <nanocryk@duniter.org>","inso <inso@tuta.io>"]
description = "DURS (Dividende Universel RuSt) is a new implementation of Duniter protocol and software in Rust, a safe, concurrent, practical language"
license = "AGPL-3.0"
[dependencies]
duniter-core = { path = "../../lib/core" }
# durs-skeleton-module = { path = "../../lib/skeleton-module" }
durs-ws2p = { path = "../../lib/ws2p" }
durs-ws2p-v1-legacy = { path = "../../lib/ws2p-v1-legacy" }
structopt= "0.2.*"
[target.'cfg(unix)'.dependencies]
duniter-tui = { path = "../../lib/tui" }
[features]
default = ["ssl"]
ssl = ["durs-ws2p-v1-legacy/ssl"]
# Treat warnings as a build error.
strict = []
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment