Commit ce88f841 authored by Éloïs's avatar Éloïs
Browse files

[deps] upgrade dubp to v0.51

parent 573e04ce
......@@ -1059,9 +1059,9 @@ checksum = "4bb454f0228b18c7f4c3b0ebbee346ed9c52e7443b0999cd543ff3571205701d"
[[package]]
name = "dubp"
version = "0.50.0"
version = "0.51.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "1669c61ccfe0d3fc7be8fe3175ebd401b9c879f638425f31e92777c73b32ea86"
checksum = "21dac0f098a82c2782208a2bbd64caf27daafbf439d783e8a2b6589efc9e3dae"
dependencies = [
"dubp-block",
"dubp-common",
......@@ -1073,9 +1073,9 @@ dependencies = [
[[package]]
name = "dubp-block"
version = "0.50.0"
version = "0.51.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "c602ecf3e703abf6492b5bb66fbd9ad658f974407a7d7d13651f6a1a26122028"
checksum = "dc7db42ae9c39478b09d08b56fe7c5acfc31317a46fe3c3ba9df3438154c1410"
dependencies = [
"dubp-documents",
"dubp-documents-parser",
......@@ -1088,9 +1088,9 @@ dependencies = [
[[package]]
name = "dubp-common"
version = "0.50.0"
version = "0.51.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "515fb09166a50b4543a99c42359fc4afa5a4c7af118c6f9627575c2760f3fef8"
checksum = "328a6ae4c29ae95253a18314cd2d7f5e04bf48a8de40a473172734e485370fd9"
dependencies = [
"dup-crypto",
"serde",
......@@ -1101,9 +1101,9 @@ dependencies = [
[[package]]
name = "dubp-documents"
version = "0.50.0"
version = "0.51.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ccc9327c62778ee4fd060c0efbe32c6cfda5e317c4a2eb4ddee8293fbd278904"
checksum = "05c501db59e9334ac22022baae5f51bb6e73d53a38b9f015015c770f83437da4"
dependencies = [
"beef",
"dubp-wallet",
......@@ -1115,9 +1115,9 @@ dependencies = [
[[package]]
name = "dubp-documents-parser"
version = "0.50.0"
version = "0.51.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "271ce4a6bebfdfdaefb0e51f57c9bb04976fce5fbe2744dd60c1dcf857c60c20"
checksum = "12c38b138c7f5b6fbc219062548e04fce72dbf263400e50b106f39dec2b94f1d"
dependencies = [
"dubp-documents",
"json-pest-parser",
......@@ -1129,9 +1129,9 @@ dependencies = [
[[package]]
name = "dubp-wallet"
version = "0.50.0"
version = "0.51.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "f6e65a121fa6745038e903ed3d1eb6a97f9658c6c6e2bfbf7e9ffdaf34161d23"
checksum = "4bc7edb25227bbcfda2026a208022cc2ab8c43be0b7923f8281d572d253085a6"
dependencies = [
"byteorder",
"dubp-common",
......@@ -1511,9 +1511,9 @@ dependencies = [
[[package]]
name = "dup-crypto"
version = "0.50.0"
version = "0.51.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "3032421000ca2cdd372bd72f4c548be7f1386d357abb0936291890064d3072e8"
checksum = "431ee425d40a19ac98b70b91b3afbbb3e5853397e95430694d07bb96a977a729"
dependencies = [
"aes",
"arrayvec",
......
......@@ -17,7 +17,7 @@ neon-build = "0.4.0"
[dependencies]
bincode = "1.2.1"
bs58 = "0.3.0"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
dubp-wot = { path = "../../rust-libs/dubp-wot" }
duniter-server = { path = "../../rust-libs/duniter-server" }
flate2 = "1.0.16"
......
......@@ -22,7 +22,7 @@ anyhow = "1.0.33"
arrayvec = "0.5.1"
comfy-table = "2.1.0"
dirs = "3.0.1"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-dbs = { path = "../../rust-libs/duniter-dbs", default-features = false, features = ["explorer", "leveldb_backend", "sled_backend"] }
duniter-dbs-write-ops = { path = "../../rust-libs/duniter-dbs-write-ops", default-features = false, features = ["explorer", "leveldb_backend", "sled_backend"] }
duniter-gva-db = { path = "../../rust-libs/modules/gva/db", default-features = false, features = ["explorer", "leveldb_backend"] }
......
......@@ -14,7 +14,7 @@ path = "src/lib.rs"
[dependencies]
anyhow = "1.0.34"
duniter-dbs = { path = "../duniter-dbs" }
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
resiter = "0.4.0"
[dev-dependencies]
......
......@@ -6,5 +6,5 @@ license = "AGPL-3.0"
edition = "2018"
[dependencies]
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
serde = { version = "1.0.105", features = ["derive"] }
......@@ -13,7 +13,7 @@ path = "src/lib.rs"
[dependencies]
chrono = "0.4.19"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-dbs = { path = "../duniter-dbs" }
duniter-global = { path = "../duniter-global" }
fast-threadpool = "0.2.3"
......
......@@ -16,7 +16,7 @@ arrayvec = "0.5.1"
bincode = "1.2.1"
byteorder = "1.3.4"
chrono = { version = "0.4.15", optional = true }
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
kv_typed = { path = "../tools/kv_typed", default-features = false }
log = "0.4.8"
mockall = { version = "0.9.1", optional = true }
......
......@@ -7,7 +7,7 @@ edition = "2018"
[dependencies]
async-rwlock = "1.3.0"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-dbs = { path = "../duniter-dbs" }
flume = "0.10"
mockall = { version = "0.9", optional = true }
......
......@@ -12,7 +12,7 @@ edition = "2018"
path = "src/lib.rs"
[dependencies]
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-dbs = { path = "../duniter-dbs" }
duniter-bc-reader = { path = "../duniter-bc-reader" }
duniter-dbs-write-ops = { path = "../duniter-dbs-write-ops" }
......
......@@ -8,7 +8,7 @@ edition = "2018"
[dependencies]
anyhow = "1.0.34"
async-trait = "0.1.41"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-conf = { path = "../duniter-conf" }
duniter-dbs = { path = "../duniter-dbs" }
duniter-global = { path = "../duniter-global" }
......
......@@ -8,7 +8,7 @@ edition = "2018"
[dependencies]
anyhow = "1.0.34"
cfg-if = "1.0.0"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-conf = { path = "../duniter-conf" }
duniter-bc-reader = { path = "../duniter-bc-reader" }
duniter-dbs = { path = "../duniter-dbs" }
......
......@@ -12,7 +12,7 @@ async-graphql = "2.2.0"
async-mutex = "1.4.0"
async-trait = "0.1.41"
bytes = "1.0"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-bca = { path = "./bca" }
duniter-conf = { path = "../../duniter-conf" }
duniter-dbs = { path = "../../duniter-dbs" }
......
......@@ -11,7 +11,7 @@ arrayvec = { version = "0.5.1", features = ["serde"] }
async-bincode = "0.6.1"
async_io_stream = { version = "0.3.1", features = [ "tokio_io"] }
bincode = "1.3"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-bca-types = { path = "types", features = ["duniter"] }
duniter-dbs = { path = "../../../duniter-dbs" }
duniter-gva-db = { path = "../db" }
......
......@@ -8,7 +8,7 @@ edition = "2018"
[dependencies]
arrayvec = { version = "0.5.1", features = ["serde"] }
bincode = "1.3"
dubp = { version = "0.50.0" }
dubp = { version = "0.51.0" }
serde = { version = "1.0.105", features = ["derive"] }
smallvec = { version = "1.4.0", features = ["serde"] }
thiserror = "1.0.20"
......
......@@ -14,7 +14,7 @@ path = "src/lib.rs"
bincode = "1.2.1"
chrono = { version = "0.4.15", optional = true }
duniter-dbs = { path = "../../../duniter-dbs" }
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
kv_typed = { path = "../../../tools/kv_typed", default-features = false, features = ["sled_backend"] }
parking_lot = "0.11.0"
paste = "1.0.2"
......
......@@ -20,7 +20,7 @@ arrayvec = "0.5.1"
duniter-bca-types = { path = "../bca/types" }
duniter-dbs = { path = "../../../duniter-dbs" }
duniter-gva-db = { path = "../db" }
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
mockall = { version = "0.9.1", optional = true }
resiter = "0.4.0"
......
......@@ -10,7 +10,7 @@ anyhow = "1.0.33"
arrayvec = "0.5.1"
async-graphql = "2.2.0"
async-trait = "0.1.41"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-conf = { path = "../../../duniter-conf" }
duniter-dbs = { path = "../../../duniter-dbs" }
duniter-bc-reader = { path = "../../../duniter-bc-reader" }
......
......@@ -15,7 +15,7 @@ path = "src/lib.rs"
anyhow = "1.0.34"
duniter-dbs = { path = "../../../duniter-dbs" }
duniter-gva-db = { path = "../db" }
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
once_cell = "1.5.2"
resiter = "0.4.0"
......
......@@ -7,7 +7,7 @@ edition = "2018"
[dependencies]
anyhow = "1.0.34"
dubp = { version = "0.50.0", features = ["duniter"] }
dubp = { version = "0.51.0", features = ["duniter"] }
duniter-conf = { path = "../../duniter-conf" }
duniter-dbs = { path = "../../duniter-dbs" }
duniter-bc-reader = { path = "../../duniter-bc-reader" }
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment