Commit a25bdb4b authored by Benoit Lavenier's avatar Benoit Lavenier
Browse files

[fix] Upgrade some library (to resolve security alerts)

parent 1ed4f499
Pipeline #3282 passed with stage
in 23 seconds
...@@ -31,16 +31,16 @@ ...@@ -31,16 +31,16 @@
<!-- Commons versions --> <!-- Commons versions -->
<duniter4j.version>1.1.0</duniter4j.version> <duniter4j.version>1.1.0</duniter4j.version>
<log4j.version>1.2.17</log4j.version> <log4j.version>1.2.17</log4j.version>
<slf4j.version>1.7.5</slf4j.version> <slf4j.version>1.7.6</slf4j.version>
<guava.version>22.0</guava.version> <guava.version>22.0</guava.version>
<xml-apis.version>2.0.2</xml-apis.version> <xml-apis.version>2.0.2</xml-apis.version>
<kalium.version>0.6.0_PR64</kalium.version> <kalium.version>0.6.0_PR64</kalium.version>
<jnr-ffi.version>2.1.7</jnr-ffi.version> <jnr-ffi.version>2.1.8</jnr-ffi.version>
<scrypt.version>1.4.0</scrypt.version> <scrypt.version>1.4.0</scrypt.version>
<elasticsearch.version>2.4.6</elasticsearch.version> <elasticsearch.version>2.4.6</elasticsearch.version>
<jna.version>4.2.0</jna.version> <jna.version>4.2.0</jna.version><!--4.3.0 could not build -->
<tyrus.version>1.13.1</tyrus.version> <tyrus.version>1.14</tyrus.version>
<jackson.version>2.8.1</jackson.version> <jackson.version>2.9.5</jackson.version>
<stringtemplate.version>4.0.2</stringtemplate.version> <stringtemplate.version>4.0.2</stringtemplate.version>
<jTextUtilsVersion>0.3.3</jTextUtilsVersion> <jTextUtilsVersion>0.3.3</jTextUtilsVersion>
...@@ -48,10 +48,6 @@ ...@@ -48,10 +48,6 @@
<nuitonVersionVersion>1.0-rc-2</nuitonVersionVersion> <nuitonVersionVersion>1.0-rc-2</nuitonVersionVersion>
<nuitonI18nVersion>3.6.3</nuitonI18nVersion> <nuitonI18nVersion>3.6.3</nuitonI18nVersion>
<!-- UI versions -->
<spring.version>4.2.1.RELEASE</spring.version>
<aspectj.version>1.8.7</aspectj.version>
<!-- Unit test --> <!-- Unit test -->
<junit.version>4.12</junit.version> <junit.version>4.12</junit.version>
<jetty.version>9.0.4.v20130625</jetty.version> <jetty.version>9.0.4.v20130625</jetty.version>
...@@ -222,7 +218,7 @@ ...@@ -222,7 +218,7 @@
<dependency> <dependency>
<groupId>commons-io</groupId> <groupId>commons-io</groupId>
<artifactId>commons-io</artifactId> <artifactId>commons-io</artifactId>
<version>2.5</version> <version>2.6</version>
</dependency> </dependency>
<dependency> <dependency>
<groupId>javax.mail</groupId> <groupId>javax.mail</groupId>
...@@ -257,17 +253,17 @@ ...@@ -257,17 +253,17 @@
<dependency> <dependency>
<groupId>org.apache.httpcomponents</groupId> <groupId>org.apache.httpcomponents</groupId>
<artifactId>httpclient</artifactId> <artifactId>httpclient</artifactId>
<version>4.3.3</version> <version>4.3.4</version>
</dependency> </dependency>
<dependency> <dependency>
<groupId>org.apache.httpcomponents</groupId> <groupId>org.apache.httpcomponents</groupId>
<artifactId>httpmime</artifactId> <artifactId>httpmime</artifactId>
<version>4.3.3</version> <version>4.3.4</version>
</dependency> </dependency>
<dependency> <dependency>
<groupId>commons-net</groupId> <groupId>commons-net</groupId>
<artifactId>commons-net</artifactId> <artifactId>commons-net</artifactId>
<version>3.3</version> <version>3.4</version>
</dependency> </dependency>
<dependency> <dependency>
<groupId>com.google.guava</groupId> <groupId>com.google.guava</groupId>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment