Commit 83494d9d authored by Benoit Lavenier's avatar Benoit Lavenier
Browse files

[fix] Fix error in Android 10 secure storage - fix #898

[fix] Change bower versions, to use exact match (to avoid error in NPM log)
[enh] Upgrade undercore lib
parent 542824b1
Pipeline #8674 failed
......@@ -123,12 +123,12 @@
<icon height="1024" src="resources/osx/icon-1024.png" width="1024" />
</platform>
<engine name="android" spec="^6.4.0" />
<engine name="ios" spec="git+https://github.com/bpresles/cordova-ios.git#5.1.0" />
<engine name="ios" spec="git+https://github.com/duniter-cesium/cordova-ios.git#5.1.0" />
<plugin name="cordova-plugin-camera" spec="^4.1.0" />
<plugin name="cordova-plugin-console" spec="^1.1.0" />
<plugin name="cordova-plugin-device" spec="^2.0.3" />
<plugin name="cordova-plugin-dialogs" spec="^2.0.2" />
<plugin name="cordova-plugin-secure-storage" spec="^3.0.2" />
<plugin name="cordova-plugin-secure-storage-android10" spec="git+https://github.com/duniter-cesium/cordova-plugin-secure-storage-android10#6.0.3" />
<plugin name="cordova-plugin-splashscreen" spec="^5.0.3" />
<plugin name="cordova-plugin-statusbar" spec="^2.4.3" />
<plugin name="cordova-plugin-vibration" spec="^3.1.1" />
......@@ -136,7 +136,7 @@
<plugin name="cordova-plugin-whitelist" spec="^1.3.4" />
<plugin name="cordova-plugin-x-toast" spec="^2.7.2" />
<plugin name="cordova-plugin-ionic-keyboard" spec="^2.2.1" />
<plugin name="cordova-plugin-minisodium" spec="https://github.com/E-IS/cordova-plugin-minisodium.git#1.0.1" />
<plugin name="cordova-plugin-minisodium" spec="git+https://github.com/duniter-cesium/cordova-plugin-minisodium.git#v1.0.1" />
<plugin name="phonegap-plugin-barcodescanner" spec="^8.1.0">
<variable name="CAMERA_USAGE_DESCRIPTION" value="To scan QRCode" />
</plugin>
......
Subproject commit 5a620ea1be8a5ad0596ba19887f6238e9a486c65
Subproject commit 074f02140b2fe1652cf67e3f12e54627dcde9190
......@@ -45,7 +45,8 @@ To build Cesium, you will have to:
3. Installing Cordova plugins (required to build Android and iOS artifacts):
```bash
ionic cordova preapre
export JAVA_HOME=/path/to/jdk-8
ionic cordova prepare
```
This should create new directories `platforms/android` and `platforms/ios`.
......
......@@ -4,6 +4,7 @@
"description": "Cesium Wallet for G1 libre currency",
"author": "Benoit Lavenier <benoit.lavenier@e-is.pro>",
"license": "AGPL-3.0",
"homepage": "https://cesium.app",
"repository": {
"type": "git",
"url": "git@git.duniter.org:clients/cesium/cesium.git"
......@@ -15,13 +16,14 @@
"start": "ionic serve",
"docker:build": "sudo docker build . -t cesium/release",
"docker:run": "sudo docker run -ti --rm -p 8100:8100 -p 35729:35729 -v .:/cesium:rw cesium/release",
"build:web": "gulp config --env default && gulp build:web --release"
"build:web": "gulp config --env default && gulp webBuild --release"
},
"keywords": [
"duniter",
"cesium",
"g1",
"ionic",
"angular",
"angularjs",
"cordova",
"crypto-currency"
],
......@@ -31,55 +33,54 @@
"new": "https://git.duniter.org/clients/cesium-grp/cesium/issues/new"
},
"dependencies": {
"@bower_components/Leaflet.EasyButton": "CliffCloud/Leaflet.EasyButton#^2.4.0",
"@bower_components/Leaflet.FeatureGroup.SubGroup": "VivekKhandre/Leaflet.FeatureGroup.SubGroup#^0.1.2",
"@bower_components/Leaflet.awesome-markers": "lvoogdt/Leaflet.awesome-markers#^2.0.2",
"@bower_components/aes-js": "ricmoo/aes-js#3.1.2",
"@bower_components/angular": "angular/bower-angular#~1.5.11",
"@bower_components/angular-animate": "angular/bower-angular-animate#~1.5.11",
"@bower_components/angular-expose-api": "e-is/angular-expose-api#^0.3.1",
"@bower_components/angular-bind-notifier": "aeisenberg/angular-bind-notifier#^1.1.11",
"@bower_components/angular-cache": "jmdobry/angular-cache#^4.6.0",
"@bower_components/angular-chart.js": "jtblin/angular-chart#^1.1.1",
"@bower_components/angular-file-saver": "alferov/angular-file-saver#^1.1.3",
"@bower_components/angular-fullscreen-toggle": "e-is/angular-fullscreen-toggle#1.0.4",
"@bower_components/angular-image-crop": "andyshora/angular-image-crop#^2.0.0",
"@bower_components/angular-leaflet-directive": "e-is/angular-leaflet-directive#0.10.1",
"@bower_components/angular-messages": "angular/bower-angular-messages#~1.5.11",
"@bower_components/angular-moment": "urish/angular-moment#^0.10.3",
"@bower_components/angular-resource": "angular/bower-angular-resource#~1.5.11",
"@bower_components/angular-sanitize": "angular/bower-angular-sanitize#~1.5.11",
"@bower_components/angular-screenmatch": "bensurman/angular-screenmatch#^1.0.1",
"@bower_components/angular-simple-logger": "nmccready/angular-simple-logger#~0.1.4",
"@bower_components/angular-translate": "PascalPrecht/bower-angular-translate#^2.18.1",
"@bower_components/angular-ui-router": "angular-ui/angular-ui-router-bower#^0.2.18",
"@bower_components/Leaflet.EasyButton": "CliffCloud/Leaflet.EasyButton#v2.4.0",
"@bower_components/Leaflet.FeatureGroup.SubGroup": "ghybs/Leaflet.FeatureGroup.SubGroup#v0.1.2",
"@bower_components/Leaflet.awesome-markers": "lvoogdt/Leaflet.awesome-markers#v2.0.2",
"@bower_components/aes-js": "ricmoo/aes-js#v3.1.2",
"@bower_components/angular": "angular/bower-angular#v1.5.11",
"@bower_components/angular-animate": "angular/bower-angular-animate#v1.5.11",
"@bower_components/angular-expose-api": "duniter-cesium/angular-expose-api#0.3.1",
"@bower_components/angular-bind-notifier": "aeisenberg/angular-bind-notifier#v1.1.11",
"@bower_components/angular-cache": "jmdobry/angular-cache#4.6.0",
"@bower_components/angular-chart.js": "jtblin/angular-chart#1.1.1",
"@bower_components/angular-file-saver": "alferov/angular-file-saver#1.1.3",
"@bower_components/angular-fullscreen-toggle": "duniter-cesium/angular-fullscreen-toggle#1.0.4",
"@bower_components/angular-image-crop": "duniter-cesium/angular-image-crop#v2.0.2",
"@bower_components/angular-leaflet-directive": "duniter-cesium/angular-leaflet-directive#0.10.1",
"@bower_components/angular-messages": "angular/bower-angular-messages#v1.5.11",
"@bower_components/angular-moment": "urish/angular-moment#1.3.0",
"@bower_components/angular-resource": "angular/bower-angular-resource#v1.5.11",
"@bower_components/angular-sanitize": "angular/bower-angular-sanitize#v1.5.11",
"@bower_components/angular-screenmatch": "bensurman/angular-screenmatch#v1.0.1",
"@bower_components/angular-simple-logger": "nmccready/angular-simple-logger#0.1.7",
"@bower_components/angular-translate": "PascalPrecht/bower-angular-translate#2.18.2",
"@bower_components/angular-ui-router": "angular-ui/angular-ui-router-bower#0.2.18",
"@bower_components/blob-polyfill": "bjornstar/blob-polyfill#~1.0.20150320",
"@bower_components/chart.js": "chartjs/Chart.js#^2.9.3",
"@bower_components/chart.js": "chartjs/Chart.js#v2.9.3",
"@bower_components/file-saver.js": "Teleborder/FileSaver.js#~1.20150507.2",
"@bower_components/ion-digit-keyboard": "skol-pro/ion-digit-keyboard#973b90c2fc",
"@bower_components/ionic": "driftyco/ionic-bower#1.3.5",
"@bower_components/ionic-material": "zachsoft/Ionic-Material#0.4.2",
"@bower_components/ionic": "driftyco/ionic-bower#v1.3.5",
"@bower_components/ionic-material": "zachsoft/Ionic-Material#v0.4.2",
"@bower_components/js-nacl": "tonyg/js-nacl#1.3.2",
"@bower_components/js-scrypt": "tonyg/js-scrypt#1.2.0",
"@bower_components/leaflet": "Leaflet/Leaflet#0.7.7",
"@bower_components/leaflet-search": "stefanocudini/leaflet-search#2.7.2",
"@bower_components/leaflet.loading": "ebrelsford/Leaflet.loading#^0.1.24",
"@bower_components/leaflet.markercluster": "Leaflet/Leaflet.markercluster#0.5.0",
"@bower_components/moment": "moment/moment#^2.24.0",
"@bower_components/ng-idle": "HackedByChinese/ng-idle#^1.3.2",
"@bower_components/ngCordova": "driftyco/ng-cordova#0.1.27-alpha",
"@bower_components/numeral": "adamwdraper/Numeral-js#^1.5.6",
"@bower_components/js-scrypt": "tonyg/js-scrypt#v1.2.0",
"@bower_components/leaflet": "Leaflet/Leaflet#v0.7.7",
"@bower_components/leaflet-search": "stefanocudini/leaflet-search#v2.7.2",
"@bower_components/leaflet.loading": "ebrelsford/Leaflet.loading#v0.1.24",
"@bower_components/leaflet.markercluster": "Leaflet/Leaflet.markercluster#v0.5.0",
"@bower_components/moment": "moment/moment#2.24.0",
"@bower_components/ng-idle": "HackedByChinese/ng-idle#1.3.2",
"@bower_components/ngCordova": "driftyco/ng-cordova#v0.1.27-alpha",
"@bower_components/numeral": "adamwdraper/Numeral-js#1.5.6",
"@bower_components/qrcode-generator": "kazuhikoarase/qrcode-generator#js1.4.4",
"@bower_components/robotodraft": "raibutera/robotodraft#1.1.0",
"@bower_components/socket.io": "socketio/socket.io#^1.7.4",
"@bower_components/socket.io-client": "socketio/socket.io-client#^1.7.4",
"@bower_components/ui-leaflet": "angular-ui/ui-leaflet#^2.0.0",
"@bower_components/underscore": "jashkenas/underscore#^1.8.3",
"@bower_components/waves": "fians/Waves#0.6",
"@bower_components/ui-leaflet": "angular-ui/ui-leaflet#v2.0.0",
"@bower_components/underscore": "jashkenas/underscore#1.10.2",
"cordova": "^9.0.0",
"cordova-android": "^8.1.0",
"cordova-clipboard": "^1.3.0",
"cordova-ios": "git+https://github.com/bpresles/cordova-ios.git#5.1.0",
"cordova-ios": "git+https://github.com/duniter-cesium/cordova-ios.git#5.1.0",
"cordova-osx": "^5.0.0",
"cordova-plugin-camera": "^4.1.0",
"cordova-plugin-compat": "^1.2.0",
......@@ -87,8 +88,8 @@
"cordova-plugin-dialogs": "^2.0.2",
"cordova-plugin-ionic-keyboard": "^2.2.0",
"cordova-plugin-ionic-webview": "^4.1.3",
"cordova-plugin-minisodium": "^1.0.0",
"cordova-plugin-secure-storage": "^3.0.2",
"cordova-plugin-minisodium": "git+https://github.com/duniter-cesium/cordova-plugin-minisodium#v1.0.1",
"cordova-plugin-secure-storage-android10": "git+https://github.com/duniter-cesium/cordova-plugin-secure-storage-android10#6.0.3",
"cordova-plugin-splashscreen": "^5.0.3",
"cordova-plugin-statusbar": "^2.4.3",
"cordova-plugin-vibration": "^3.1.1",
......@@ -142,10 +143,12 @@
"node-sass": "^4.13.0",
"playup": "^1.1.0",
"vinyl-fs": "^3.0.3",
"yargs": "^5.0.0"
"yargs": "^5.0.0",
"cordova-plugin-secure-storage-android10": "duniter-cesium/cordova-plugin-secure-storage-android10#^6.0.3"
},
"peerDependencies": {
"nopt": "4.0.1"
"nopt": "4.0.1",
"leaflet": "Leaflet/Leaflet#v0.7.7"
},
"cordovaPlugins": [
"cordova-plugin-whitelist",
......@@ -157,7 +160,7 @@
"cordova-plugin-websocket",
"cordova-plugin-vibration",
"cordova-plugin-dialogs",
"cordova-plugin-secure-storage",
"cordova-plugin-secure-storage-android10",
"cordova-plugin-x-toast",
"cordova-clipboard",
"cordova-plugin-minisodium",
......@@ -169,7 +172,7 @@
{
"platform": "ios",
"version": "5.1.0",
"locator": "https://github.com/bpresles/cordova-ios.git#5.1.0"
"locator": "https://github.com/duniter-cesium/cordova-ios.git#5.1.0"
},
{
"platform": "android",
......@@ -186,7 +189,7 @@
"cordova-plugin-device": {},
"cordova-plugin-dialogs": {},
"cordova-plugin-minisodium": {},
"cordova-plugin-secure-storage": {},
"cordova-plugin-secure-storage-android10": {},
"cordova-plugin-splashscreen": {},
"cordova-plugin-statusbar": {},
"cordova-plugin-vibration": {},
......@@ -201,7 +204,8 @@
"cordova-clipboard": {},
"cordova-plugin-ionic-webview": {
"ANDROID_SUPPORT_ANNOTATIONS_VERSION": "27.+"
}
},
"cordova-plugin-console": {}
},
"platforms": [
"ios",
......
......@@ -16,7 +16,7 @@
<!-- build:css dist_css/cesium.css -->
<link rel="stylesheet" type="text/css" href="css/ionic.app.css">
<link rel="stylesheet" type="text/css" href="css/style.css">
<link rel="stylesheet" type="text/css" href="lib/angular-image-crop/image-crop-styles.css">
<link rel="stylesheet" type="text/css" href="lib/angular-image-crop/dist/angular-image-crop.min.css">
<!-- removeIf(device) -->
<link rel="stylesheet" type="text/css" href="css/style-no-device.css">
<!-- endRemoveIf(device) -->
......@@ -96,7 +96,7 @@
<script src="lib/angular-cache/dist/angular-cache.min.js"></script>
<script src="lib/angular-screenmatch/dist/angular-screenmatch.min.js"></script>
<script src="lib/angular-bind-notifier/dist/angular-bind-notifier.min.js"></script>
<script src="lib/angular-image-crop/image-crop.js"></script>
<script src="lib/angular-image-crop/dist/angular-image-crop.js"></script>
<script src="lib/angular-file-saver/dist/angular-file-saver.bundle.min.js"></script>
<script src="lib/ng-idle/angular-idle.min.js"></script>
<script src="lib/angular-simple-logger/dist/angular-simple-logger.light.min.js"></script>
......
......@@ -2,111 +2,113 @@
# yarn lockfile v1
"@bower_components/Leaflet.EasyButton@CliffCloud/Leaflet.EasyButton#^2.4.0":
"@bower_components/Leaflet.EasyButton@CliffCloud/Leaflet.EasyButton#v2.4.0":
version "2.4.0"
resolved "https://codeload.github.com/CliffCloud/Leaflet.EasyButton/tar.gz/6f4b04751eac9d0d1fc7a3cc5ad384c516f601ee"
dependencies:
leaflet "^1.0.1"
"@bower_components/Leaflet.FeatureGroup.SubGroup@VivekKhandre/Leaflet.FeatureGroup.SubGroup#^0.1.2":
"@bower_components/Leaflet.FeatureGroup.SubGroup@ghybs/Leaflet.FeatureGroup.SubGroup#v0.1.2":
version "0.1.2"
resolved "https://codeload.github.com/VivekKhandre/Leaflet.FeatureGroup.SubGroup/tar.gz/2ec699f11e1b6a8fa2596a1bb2b7a144d162c6d6"
resolved "https://codeload.github.com/ghybs/Leaflet.FeatureGroup.SubGroup/tar.gz/2ec699f11e1b6a8fa2596a1bb2b7a144d162c6d6"
"@bower_components/Leaflet.awesome-markers@lvoogdt/Leaflet.awesome-markers#^2.0.2":
"@bower_components/Leaflet.awesome-markers@lvoogdt/Leaflet.awesome-markers#v2.0.2":
version "0.0.0"
resolved "https://codeload.github.com/lvoogdt/Leaflet.awesome-markers/tar.gz/bfac1eb6f7896072d690bde57c1fb5002961a99a"
"@bower_components/aes-js@ricmoo/aes-js#3.1.2":
"@bower_components/aes-js@ricmoo/aes-js#v3.1.2":
version "3.1.2"
resolved "https://codeload.github.com/ricmoo/aes-js/tar.gz/7c9fad4add4b349dcb89a4e2125f37defaef3bc8"
"@bower_components/angular-animate@angular/bower-angular-animate#~1.5.11":
"@bower_components/angular-animate@angular/bower-angular-animate#v1.5.11":
version "1.5.11"
resolved "https://codeload.github.com/angular/bower-angular-animate/tar.gz/ac17971fdc62d7ea816a079401084e6da2af3e3e"
"@bower_components/angular-bind-notifier@aeisenberg/angular-bind-notifier#^1.1.11":
"@bower_components/angular-bind-notifier@aeisenberg/angular-bind-notifier#v1.1.11":
version "1.1.11"
resolved "https://codeload.github.com/aeisenberg/angular-bind-notifier/tar.gz/4c3adcdb20a97f541312706046a73ba12e03326d"
"@bower_components/angular-cache@jmdobry/angular-cache#^4.6.0":
"@bower_components/angular-cache@jmdobry/angular-cache#4.6.0":
version "4.6.0"
resolved "https://codeload.github.com/jmdobry/angular-cache/tar.gz/b491ed8361cd092dd82e59eab0031a2e202900a6"
"@bower_components/angular-chart.js@jtblin/angular-chart#^1.1.1":
"@bower_components/angular-chart.js@jtblin/angular-chart#1.1.1":
version "1.1.1"
resolved "https://codeload.github.com/jtblin/angular-chart/tar.gz/74c95397d39fb7424aa245badebe92bc6f9248f5"
dependencies:
angular "1.x"
chart.js "2.3.x"
"@bower_components/angular-expose-api@e-is/angular-expose-api#^0.3.1":
"@bower_components/angular-expose-api@duniter-cesium/angular-expose-api#0.3.1":
version "0.3.1"
resolved "https://codeload.github.com/e-is/angular-expose-api/tar.gz/6fc193c3453b73354f256c816ce098dfd89e7bc8"
resolved "https://codeload.github.com/duniter-cesium/angular-expose-api/tar.gz/6fc193c3453b73354f256c816ce098dfd89e7bc8"
dependencies:
angular "^1.5.11"
"@bower_components/angular-file-saver@alferov/angular-file-saver#^1.1.3":
"@bower_components/angular-file-saver@alferov/angular-file-saver#1.1.3":
version "1.1.3"
resolved "https://codeload.github.com/alferov/angular-file-saver/tar.gz/bdba5fab87f5a9f53c1320421ed789dc219892e9"
dependencies:
blob-tmp "^1.0.0"
file-saver "^1.3.3"
"@bower_components/angular-fullscreen-toggle@e-is/angular-fullscreen-toggle#1.0.4":
"@bower_components/angular-fullscreen-toggle@duniter-cesium/angular-fullscreen-toggle#1.0.4":
version "1.0.4"
resolved "https://codeload.github.com/e-is/angular-fullscreen-toggle/tar.gz/74c7037c508046afdf449f003b3c50190dcd4cf3"
resolved "https://codeload.github.com/duniter-cesium/angular-fullscreen-toggle/tar.gz/74c7037c508046afdf449f003b3c50190dcd4cf3"
dependencies:
angular "^1.5.11"
"@bower_components/angular-image-crop@andyshora/angular-image-crop#^2.0.0":
version "0.0.0"
resolved "https://codeload.github.com/andyshora/angular-image-crop/tar.gz/d8de6ea4f9ff5c3941399f28dc798aa8da884603"
"@bower_components/angular-image-crop@duniter-cesium/angular-image-crop#v2.0.2":
version "2.0.2"
resolved "https://codeload.github.com/duniter-cesium/angular-image-crop/tar.gz/4a47439dcb82541f15b0ce6389762522e73445bd"
dependencies:
angular "^1.5.11"
"@bower_components/angular-leaflet-directive@e-is/angular-leaflet-directive#0.10.1":
"@bower_components/angular-leaflet-directive@duniter-cesium/angular-leaflet-directive#0.10.1":
version "0.10.1"
resolved "https://codeload.github.com/e-is/angular-leaflet-directive/tar.gz/1cfbdf4a7f68bfddddc7472b5799c7b950337b2a"
resolved "https://codeload.github.com/duniter-cesium/angular-leaflet-directive/tar.gz/1cfbdf4a7f68bfddddc7472b5799c7b950337b2a"
dependencies:
angular "1.x"
leaflet "0.7.x"
"@bower_components/angular-messages@angular/bower-angular-messages#~1.5.11":
"@bower_components/angular-messages@angular/bower-angular-messages#v1.5.11":
version "1.5.11"
resolved "https://codeload.github.com/angular/bower-angular-messages/tar.gz/4853e43f00243d582b4f6145b6096129ca91fbdf"
"@bower_components/angular-moment@urish/angular-moment#^0.10.3":
version "0.10.3"
resolved "https://codeload.github.com/urish/angular-moment/tar.gz/07d373b7a2fd17ff25ab927ff7fcb0b53b2d13fd"
"@bower_components/angular-moment@urish/angular-moment#1.3.0":
version "1.3.0"
resolved "https://codeload.github.com/urish/angular-moment/tar.gz/aa3e39f77214da5a718755a3582aac517a53a04f"
dependencies:
moment ">=2.8.0 <2.11.0"
moment ">=2.8.0 <3.0.0"
"@bower_components/angular-resource@angular/bower-angular-resource#~1.5.11":
"@bower_components/angular-resource@angular/bower-angular-resource#v1.5.11":
version "1.5.11"
resolved "https://codeload.github.com/angular/bower-angular-resource/tar.gz/9c261ab3b6afb7d6ac5b09d0d2191ed7d6c77f80"
"@bower_components/angular-sanitize@angular/bower-angular-sanitize#~1.5.11":
"@bower_components/angular-sanitize@angular/bower-angular-sanitize#v1.5.11":
version "1.5.11"
resolved "https://codeload.github.com/angular/bower-angular-sanitize/tar.gz/84df06c4ec4f1eef7f9d0b849b9fdf5433c2669c"
"@bower_components/angular-screenmatch@bensurman/angular-screenmatch#^1.0.1":
"@bower_components/angular-screenmatch@bensurman/angular-screenmatch#v1.0.1":
version "1.0.0"
resolved "https://codeload.github.com/bensurman/angular-screenmatch/tar.gz/fd5d2f40ed1878ba3eafc108e47eafc2f069810d"
"@bower_components/angular-simple-logger@nmccready/angular-simple-logger#~0.1.4":
"@bower_components/angular-simple-logger@nmccready/angular-simple-logger#0.1.7":
version "0.1.7"
resolved "https://codeload.github.com/nmccready/angular-simple-logger/tar.gz/bd15d5a9875761c9564d0c82698460980bca4c9a"
dependencies:
angular "^1.2"
debug "^2.2.0"
"@bower_components/angular-translate@PascalPrecht/bower-angular-translate#^2.18.1":
"@bower_components/angular-translate@PascalPrecht/bower-angular-translate#2.18.2":
version "0.0.0"
resolved "https://codeload.github.com/PascalPrecht/bower-angular-translate/tar.gz/a37d868d24a8aee0eabd457773e1d35297e9bd4f"
resolved "https://codeload.github.com/PascalPrecht/bower-angular-translate/tar.gz/a0a63185d2f496c388b9c3b021405bd137045673"
"@bower_components/angular-ui-router@angular-ui/angular-ui-router-bower#^0.2.18":
"@bower_components/angular-ui-router@angular-ui/angular-ui-router-bower#0.2.18":
version "0.0.0"
resolved "https://codeload.github.com/angular-ui/angular-ui-router-bower/tar.gz/2b8d5241b4c631ca2aef079bb96690b213eff449"
"@bower_components/angular@angular/bower-angular#~1.5.11":
"@bower_components/angular@angular/bower-angular#v1.5.11":
version "1.5.11"
resolved "https://codeload.github.com/angular/bower-angular/tar.gz/0f57428c3ffe2f486264ab7fbee3968dccc7b720"
......@@ -114,7 +116,7 @@
version "1.0.20150320"
resolved "https://codeload.github.com/bjornstar/blob-polyfill/tar.gz/1ea5fce0ecc5b0efde6506b1e563828f9a489ebd"
"@bower_components/chart.js@chartjs/Chart.js#^2.9.3":
"@bower_components/chart.js@chartjs/Chart.js#v2.9.3":
version "2.9.3"
resolved "https://codeload.github.com/chartjs/Chart.js/tar.gz/06f73dc3590084b2c464bf08189c7aee2b6b92d2"
dependencies:
......@@ -129,7 +131,7 @@
version "1.0.0"
resolved "https://codeload.github.com/skol-pro/ion-digit-keyboard/tar.gz/973b90c2fcb80d2ed3c4a36367a3c9a969ed8253"
"@bower_components/ionic-material@zachsoft/Ionic-Material#0.4.2":
"@bower_components/ionic-material@zachsoft/Ionic-Material#v0.4.2":
version "0.4.0"
resolved "https://codeload.github.com/zachsoft/Ionic-Material/tar.gz/bd95a3d8091212cf6df4c46693abf53c5780263e"
dependencies:
......@@ -141,7 +143,7 @@
gulp-uglify "^0.2.1"
lodash "^3.9.1"
"@bower_components/ionic@driftyco/ionic-bower#1.3.5":
"@bower_components/ionic@driftyco/ionic-bower#v1.3.5":
version "0.0.0"
resolved "https://codeload.github.com/driftyco/ionic-bower/tar.gz/816a8b26fae3e8305162eefe1114415503391be6"
......@@ -149,41 +151,41 @@
version "1.3.2"
resolved "https://codeload.github.com/tonyg/js-nacl/tar.gz/883f9d3cd9b6bbce84dc489ae4c2d87ffd653a18"
"@bower_components/js-scrypt@tonyg/js-scrypt#1.2.0":
"@bower_components/js-scrypt@tonyg/js-scrypt#v1.2.0":
version "0.0.0"
resolved "https://codeload.github.com/tonyg/js-scrypt/tar.gz/a3c516d6f51713066ef6954ed09e0e66dab23e15"
"@bower_components/leaflet-search@stefanocudini/leaflet-search#2.7.2":
"@bower_components/leaflet-search@stefanocudini/leaflet-search#v2.7.2":
version "2.7.2"
resolved "https://codeload.github.com/stefanocudini/leaflet-search/tar.gz/1b15fad4fdb5be0bdac8aa8883fab864e8675dc5"
dependencies:
leaflet "*"
"@bower_components/leaflet.loading@ebrelsford/Leaflet.loading#^0.1.24":
"@bower_components/leaflet.loading@ebrelsford/Leaflet.loading#v0.1.24":
version "0.1.24"
resolved "https://codeload.github.com/ebrelsford/Leaflet.loading/tar.gz/a1329ac02d709e9b63416b5cb09cea861a37fb4a"
"@bower_components/leaflet.markercluster@Leaflet/Leaflet.markercluster#0.5.0":
"@bower_components/leaflet.markercluster@Leaflet/Leaflet.markercluster#v0.5.0":
version "0.5.0"
resolved "https://codeload.github.com/Leaflet/Leaflet.markercluster/tar.gz/232e93ccbe5b70241913f47a4d1a8ceec8c88c30"
dependencies:
leaflet "~0.7.1"
"@bower_components/leaflet@Leaflet/Leaflet#0.7.7":
"@bower_components/leaflet@Leaflet/Leaflet#v0.7.7":
version "0.7.7"
resolved "https://codeload.github.com/Leaflet/Leaflet/tar.gz/197f9d43b7bbc73c0492bf62cd666a5a98038098"
"@bower_components/moment@moment/moment#^2.24.0":
"@bower_components/moment@moment/moment#2.24.0":
version "2.24.0"
resolved "https://codeload.github.com/moment/moment/tar.gz/96d0d6791ab495859d09a868803d31a55c917de1"
"@bower_components/ng-idle@HackedByChinese/ng-idle#^1.3.2":
"@bower_components/ng-idle@HackedByChinese/ng-idle#1.3.2":
version "1.3.2"
resolved "https://codeload.github.com/HackedByChinese/ng-idle/tar.gz/7072c91d8c619a1817e7726a0fddaf0c8e525456"
dependencies:
angular "^1.2.0"
"@bower_components/ngCordova@driftyco/ng-cordova#0.1.27-alpha":
"@bower_components/ngCordova@driftyco/ng-cordova#v0.1.27-alpha":
version "0.1.27-alpha"
resolved "https://codeload.github.com/driftyco/ng-cordova/tar.gz/6463412ad3d3dc91972db846c005aded841824ba"
dependencies:
......@@ -192,7 +194,7 @@
gulp-git "^1.2.4"
q "^1.1.2"
"@bower_components/numeral@adamwdraper/Numeral-js#^1.5.6":
"@bower_components/numeral@adamwdraper/Numeral-js#1.5.6":
version "1.5.6"
resolved "https://codeload.github.com/adamwdraper/Numeral-js/tar.gz/b598d6eeaf7981be55840d5fda5541e598eaf04f"
......@@ -232,7 +234,7 @@
socket.io-client "1.7.4"
socket.io-parser "2.3.1"
"@bower_components/ui-leaflet@angular-ui/ui-leaflet#^2.0.0":
"@bower_components/ui-leaflet@angular-ui/ui-leaflet#v2.0.0":
version "2.0.0"
resolved "https://codeload.github.com/angular-ui/ui-leaflet/tar.gz/a7b398d989dd3392f84ed2ce75569421444f2c36"
dependencies:
......@@ -240,13 +242,9 @@
angular-simple-logger "0.1.x"
leaflet "0.7.x"
"@bower_components/underscore@jashkenas/underscore#^1.8.3":
version "1.9.1"
resolved "https://codeload.github.com/jashkenas/underscore/tar.gz/ae037f7c41323807ae6f1533c45512e6d31a1574"
"@bower_components/waves@fians/Waves#0.6":
version "0.6.6"
resolved "https://codeload.github.com/fians/Waves/tar.gz/7cfc479b8246e6d15e660bc2a69fa5b3a792ce98"
"@bower_components/underscore@jashkenas/underscore#1.10.2":
version "1.10.2"
resolved "https://codeload.github.com/jashkenas/underscore/tar.gz/2a932470303157072015d5ab7f26d40b9deb4634"
"@gulp-sourcemaps/identity-map@1.X":
version "1.0.2"
......@@ -2101,15 +2099,13 @@ cordova-plugin-ionic-webview@^4.1.3:
resolved "https://registry.yarnpkg.com/cordova-plugin-ionic-webview/-/cordova-plugin-ionic-webview-4.1.3.tgz#7f3963208708951fedd975c0808a5d27382812a7"
integrity sha512-hlrUF0kLjjEkZmpYlLJO0NnXmVjMmQ3MOZVXm1ytDihLPKHklYCOpCvjA5Wz3hJrPD1shFEsqi/SPnp873AsdQ==
cordova-plugin-minisodium@^1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/cordova-plugin-minisodium/-/cordova-plugin-minisodium-1.0.0.tgz#ad6aec73c2595022f5a901545715d2a1be6665dd"
integrity sha1-rWrsc8JZUCL1qQFUVxXSob5mZd0=
cordova-plugin-minisodium@duniter-cesium/cordova-plugin-minisodium#^1.0.1:
version "1.0.1"
resolved "https://codeload.github.com/duniter-cesium/cordova-plugin-minisodium/tar.gz/507256bc140c4c45442f38a510637cda8915f9a9"
cordova-plugin-secure-storage@^3.0.2:
version "3.0.2"
resolved "https://registry.yarnpkg.com/cordova-plugin-secure-storage/-/cordova-plugin-secure-storage-3.0.2.tgz#20e51072c2fc86bf3e6238896436080aba1b283c"
integrity sha512-ZwVSPuw+SRObjH51nV/8eNR6OujSfJGZEobpR4SyKyaUy+hTy5nyAJAHNf5CSm+a8Yp+hN9TW34ztpia9kT7Ig==
cordova-plugin-secure-storage-android10@duniter-cesium/cordova-plugin-secure-storage-android10#^6.0.3:
version "6.0.3"
resolved "https://codeload.github.com/duniter-cesium/cordova-plugin-secure-storage-android10/tar.gz/ebbc7710601db6b30a8b9a915e4ae3998ccdfd52"
cordova-plugin-splashscreen@^5.0.3:
version "5.0.3"
......@@ -6429,12 +6425,7 @@ mkdirp@^1.0.3:
resolved "https://registry.yarnpkg.com/mkdirp/-/mkdirp-1.0.4.tgz#3eb5ed62622756d79a5f0e2a221dfebad75c2f7e"
integrity sha512-vVqVZQyf3WLx2Shd0qJ9xuvqgAyKPLAiqITEtqW0oIUjzo3PePDd6fW9iFz30ef7Ysp/oiWqbhszeGWW2T6Gzw==
"moment@>=2.8.0 <2.11.0":
version "2.10.6"
resolved "https://registry.yarnpkg.com/moment/-/moment-2.10.6.tgz#6cb21967c79cba7b0ca5e66644f173662b3efa77"
integrity sha1-bLIZZ8ecunsMpeZmRPFzZis++nc=
moment@^2.10.2, moment@^2.10.6:
"moment@>=2.8.0 <3.0.0", moment@^2.10.2, moment@^2.10.6:
version "2.24.0"
resolved "https://registry.yarnpkg.com/moment/-/moment-2.24.0.tgz#0d055d53f5052aa653c9f6eb68bb5d12bf5c2b5b"
integrity sha512-bV7f+6l2QigeBBZSM/6yTNq4P2fNpSWj/0e7jQcy87A8e7o2nAfP/34/2ky5Vw4B9S446EtIhodAzkFCcR4dQg==
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment